[Résolu] Problème de configuration de clavier

[Résolu] Problème de configuration de clavier

Messagepar maudmontgomery » 07 Fév 2009, 21:45

Bonjour,
je suis nouvelle sous Linux. J'ai installé Xubuntu 8.04 sur mon vieux portable depuis moins d'une semaine. J'ai trouvé la solution à plusieurs de mes désagréments, dont mon écran qui n'était pas pleine grandeur, en faisant des recherches sur Internet. Par contre, je n'ai toujours pas trouver la configuration que je cherche pour mon clavier. Comme j'ai appris la dactylographie, je ne souhaite pas devoir apprendre une nouvelle configuration. Ma question est en 2 volets :

1) Sauf erreur, j'ai essayé chacun des choix pour le Canada. Je cherche une configuration ou je dois taper sur deux touches pour faire les accents. J'avais "Français (Canada)" sous Windows XP. Je présume que ça existe sous Linux aussi. Ce serait sous quel nom?

2) Par défaut, il m'indique le modèle "PC générique 105 (intl)". Sauf que le clavier intégré au portable n'a que 86 touches. Je vois un choix avec Toshiba mais c'est "Toshiba Satellite S3000". Quel modèle devrais-je choisir?

Merci à l'avance pour votre aide.
Dernière édition par maudmontgomery le 10 Fév 2009, 12:29, édité 1 fois au total.
Portable TOSHIBA Satellite 1800, 1.1 Ghz, 256 Mo, Board:Toshiba Portable PC Version A0, 20 Go (14,7 Go libre), Xubuntu 8.04 Hardy Heron
maudmontgomery
 
Messages: 56
Inscrit le: 24 Sep 2006, 13:25
Localisation: Bécancour

Messagepar philefou » 10 Fév 2009, 02:31

Bonjour,

Puisque je ne connais pas vriament XFCE (interface graphique de Xubuntu) je ne peux pas vraiment vous indiquer comment changer le clavier dans l'interface graphique. Cependant, vous pouvez modifier le fichier de configuration de l'interface graphique (en mode super-utilisateur "root").

/etc/X11/xorg.conf

Vous devriez voir une section comme la suivante:
Code: Tout sélectionner
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Option      "AutoRepeat" "500 30"
        Option      "XkbRules" "xorg"
        Option      "XkbModel" "pc105"
        Option      "XkbLayout" "ca"
        Option      "XkbVariant" "fr"
EndSection

La seule différence devrait être le XkbLayout et XkbVariant que vous devez changer pour les valeurs indiquées ci-haut.

N'hésitez pas si vous avez d'autres questions!
philefou
 
Messages: 36
Inscrit le: 10 Mars 2007, 00:51
Localisation: Montréal

Messagepar maudmontgomery » 10 Fév 2009, 12:28

Bonjour,
merci de me répondre. Je sais où aller pour configurer les préférences de mon clavier. Je n'ai peut-être pas été assez claire mais c'est au niveau de ce que je dois choisir (quel modèle et quel "layout") que j'avais un problème. Le XkbLayout et XkbVariant du fichier xorg.conf étaient déjà comme dans ton message. Suite à cette vérification, j'ai coché la ligne "Use X configuration" (je l'avais décoché pour certains de mes essais) dans mon gestionnaire de paramètres pour le clavier et ça semble être exactement les mêmes caractères que ce qui est indiqué sur les touches du clavier. Merci beaucoup. :-D Ce n'était pas un désagrément qui empêchait le bon fonctionnement du reste de l'ordinateur mais c'était frustrant quand je voulais taper tout ce qui n'est pas lettre non accentuée ou chiffre.
Portable TOSHIBA Satellite 1800, 1.1 Ghz, 256 Mo, Board:Toshiba Portable PC Version A0, 20 Go (14,7 Go libre), Xubuntu 8.04 Hardy Heron
maudmontgomery
 
Messages: 56
Inscrit le: 24 Sep 2006, 13:25
Localisation: Bécancour


Retour vers Linux

Qui est en ligne ?

Utilisateur(s) parcourant actuellement ce forum : Aucun utilisateur inscrit et 1 invité